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1 Introduction 

Kindle Previewer is a free desktop application that enables authors, publishers, and eBook service 

providers to preview how their eBooks will appear when delivered to Kindle customers, and makes it 

easy to audit eBooks for different screen sizes, display orientations, and font sizes. Kindle Previewer 

supports previewing your eBook with the latest typographic and layout improvements that come with 

Enhanced Typesetting. Some of these improvements include higher quality images, better table 

formatting and font alignments, smoother word spacing, hyphenation, kerning, and ligatures. 

Kindle Previewer is designed to help authors, publishers, and eBook converters produce the highest-

quality Kindle eBooks. You can use the Kindle Previewer user interface to navigate through your eBook 

quickly and easily to confirm that it is ready to be published to the Kindle Store and downloaded to 

Kindle devices and applications. To validate multiple files, you can run Kindle Previewer from a 

command-line interface. 

1.1 Quick Start 

See sections 1.2 and 1.3 for system requirements and installation steps. Once you have successfully 

installed Kindle Previewer, sections 1.1.1 through 1.1.3 provide examples of how you can preview 

eBooks with Kindle Previewer. 

1.1.1 Opening Your eBook 

To open your eBook, drag and drop the file into the dotted line box on Kindle Previewer (see Figure 1) or 

click File > Open Book to select the file.  

Your eBook should be in one of the following formats: .epub, .mobi, .htm, .html, .xhtml, .opf, .kpf, .doc, 

or .docx. Support for .doc and .docx is currently limited to English language content. 

 

Figure 1: Initial display 

https://www.amazon.com/gp/feature.html?docId=1000765261
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While your file is imported, Kindle Previewer displays a set of rotating screens that tell you more about 

the features.  

When conversion finishes, thumbnail images of your eBook are displayed in the Thumbnail pane and an 

image of how your eBook will look on a tablet device is displayed in the Previewer pane (see Figure 2).  

 

Figure 2: Kindle Previewer Workspace (Windows) 

Note: If you see a tablet device window and no thumbnails, it might be because your eBook is fixed-

layout or does not support Enhanced Typesetting (see section 2.1 for details). 

In the Preview Options section, choose a device from the Device Type list and adjust the Font and Size 

to your preference. 

1.1.2 Scanning through Your eBook 

You can quickly scan through your eBook using the features of Kindle Previewer: 

• Use the Thumbnail pane:  

o Scroll through the thumbnails to see how the overall layout of your eBook appears to a 

Kindle customer.  

o In the Preview Options section, use the Page Size slider to increase or decrease the size 

of the thumbnails. This adjusts the size of the preview page and does not affect the 

actual content in any way. 

o To get a full view of the thumbnails, set the Page Size slider in a position comfortable for 

you and close the Previewer pane.  

o To bring back the Previewer pane, click a thumbnail. 
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o Use Auto-Advance View: Click the Auto-Advance View button in the Navigation 

section. When you click the Auto-Advance View button, Kindle Previewer navigates 

through your eBook automatically. You can pause, play, change speed, or click through 

pages manually from this view. 

1.1.3 Previewing Select Aspects of Your eBook 

To preview select aspects of your eBook such as images, tables, links, lists, or drop caps, click the View 

All menu and choose an option from the list (see Figure 3).  

• Examples: If you choose Images, Kindle Previewer shows all pages with images in your eBook. If 

you choose Drop Caps, Kindle Previewer shows all pages with drop caps in your eBook.  

 

Figure 3: View All list 

• You can scroll through these pages in the Thumbnail pane, click through them manually using 

the arrows in the Previewer pane, or navigate through them automatically using Auto-Advance 

View. 

• To search for pages with specific text, use Search at the top of Kindle Previewer and then use 

Auto-Advance View to automatically preview all pages with the search results.  

• To preview pages corresponding to a specific location, use the Location box in the Navigation 

section. 

1.1.4 Validate multiple books with Kindle Previewer 

To validate multiple files and get a summary of the validation status, errors, and warnings, you can run 

Kindle Previewer from a command-line interface. If your book supports Enhanced Typesetting, you can 

use the generated output file (KPF) to preview the book on Kindle Previewer user interface without 

having to reconvert the book. Run “kindlepreviewer –help” from your command line interface to get 

started. 
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1.2 System Requirements 

• Windows 7 or later 

• Intel Mac OS X 10.9 or later 

1.3 Installing Kindle Previewer 

1.3.1 Installing on Microsoft Windows® Systems 

To install Kindle Previewer on a Microsoft Windows® system, do the following: 

1. Download the Kindle Previewer installer to your computer. 

2. Double-click the KindlePreviewerInstaller.exe file to launch the installer.  

3. Review the Software End User License Agreement and then click I Agree. 

4. Select the installation folder. The default path for installing Kindle Previewer on a PC is: 

c:\Users\[user]\AppData\Local\Amazon\Kindle Previewer 3\  

To install Kindle Previewer in different location on your computer, click Browse and select 
the target folder. 

5. Wait a moment for the installation to complete. You can now launch Kindle Previewer. 

1.3.2 Installing on macOS® Systems 

To install Kindle Previewer on a macOS® system, do the following: 

1. Download the Kindle Previewer Installer to your computer. 

2. Double-click the KindlePreviewerInstaller.pkg file to launch the installer. 

3. Select a language for the installer, review the Software End User License Agreement, and then 

click Continue. 

4. In the confirmation pop-up, click Agree. 

5. Select the disk where you want to install Kindle Previewer and then click Continue. 

6. A confirmation message appears. Click Install. 

7. When you are prompted to enter your username and password, enter them and then click 

Install Software. 

8. Wait a moment for the installation to complete. You can now launch Kindle Previewer. 

1.4 Changing Language Settings 

Kindle Previewer is available in German, English, Spanish, French, Italian, Dutch, Portuguese, Chinese, 

and Japanese. To change the language of the Kindle Previewer display, select View > Language and then 

choose your preferred language.  

1.5 Supported Languages 

Kindle Previewer supports books in Afrikaans, Alsatian, Arabic, Basque, Bokmal Norwegian, Breton, 

Catalan, Chinese (Simplified), Cornish, Corsican, Danish, Dutch, Eastern Frisian, English, Finnish, French, 
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Frisian, Galician, German, Icelandic, Irish, Italian, Japanese, Luxembourgish, Manx, Northern Frisian, 

Norwegian, Nynorsk Norwegian, Portuguese, Provencal, Romansh, Scots, Scottish Gaelic, Spanish, 

Swedish, Welsh, and the Indian languages Malayalam, Tamil, Hindi, Gujarati, and Marathi.  

1.6 Importing and Exporting Files 

1.6.1 Supported Import File Formats 

Kindle Previewer can display eBooks created in the following file formats: 

• .kpf 

• .mobi 

• .azw 

• .epub 

• .htm 

• .html 

• .xhtml 

• .opf 

• .prc 

• .azw3 

• .azw8 

• .doc* 

• .docx* 

*Note: Support for this file format is currently limited to English language content.   

1.6.2 Supported Export File Formats 

Kindle Previewer can export eBooks to the following file formats: 

• .mobi 

• .azk 

To export an eBook, click the menu and select File > Export, then choose the desired file format. 

Export is typically used to sideload an eBook to a legacy Kindle reading application or device that does 

not support Enhanced Typesetting. If your eBook supports Enhanced Typesetting, sideloading to latest 

devices will not provide an accurate preview of those layout and typographic improvements. You can 

use Kindle Previewer to confirm that your eBook supports Enhanced Typesetting as described in section 

2.1. 

Note: If you are unable to export or the export option is disabled, it might be due to the following 

reasons: 
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• If you are previewing a .kpf file, the export option is disabled. You can preview the file on Kindle 

Previewer and then upload the .kpf file to Amazon. 

• Kindle Previewer does not support export to .mobi or .azk when the language of the book is 

Arabic or one of the Indian languages. These languages are available only with Enhanced 

Typesetting features, and .mobi/.azk files do not support Enhanced Typesetting. 

• If you are using ePub or other HTML-based formats, make sure that you have defined the right 

language, and remove any unnecessary language definitions. Some third-party tools add 

additional language definitions that are not necessary, which might be preventing Kindle 

Previewer from exporting your book. 

1.7 Kindle Devices Simulated 

Kindle eBooks work uniformly across platforms, but may look different to readers depending on the 

screen size of the device. Kindle Previewer allows you to preview your eBook on the following device 

types: 

• Tablet: Preview how your eBook displays on devices with larger screens, such as Fire 
tablets, Apple iPads, and Android tablets. 

• Phone:  Preview how your eBook displays on devices with a smaller screen, such as 
phones. 

• Kindle E-reader: Preview how your eBook displays on Kindle E-readers such as 
Paperwhite, Voyage, and Oasis 

1.8 Kindle Previewer Workspace 

The following sections describe the features of the Kindle Previewer workspace, which includes the 

Preview and Navigation Options pane, the Thumbnail pane (when enabled), and the Previewer pane 

(see Figure 4 and Figure 5). 
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Figure 4: Kindle Previewer Workspace (Windows) 

 

Figure 5: Kindle Previewer Workspace (Mac) 

1.8.1  Preview and Navigation Options Pane 

The Preview and Navigation Options pane changes how your eBook is displayed in the Previewer pane. 

By adjusting the options in the Preview and Navigation Options pane, you can preview your eBook in a 

variety of settings on the available device types. 

• Use the options in the Preview Options section to change the Device Type, Orientation, 
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Font, Font Size, and/or Page Size in the preview. 

• If your eBook supports Enhanced Typesetting, the Enhanced Typesetting label is displayed 
under the Auto-Advance View option as shown in Figure 6. 

• If your eBook supports Enhanced Typesetting, use the Page Size slider to adjust the zoom 
level in the Thumbnail pane (see Figure 6).  

• Use the Table of Contents section to view and explore your eBook’s navigation file (see 
Figure 6). Clicking an entry takes you to that location. 

 

Figure 6:  Preview and Navigation Options pane 

1.8.2 Thumbnail Pane 

When enabled, the Thumbnail pane displays small images of your eBook pages that you can use to: 

•  Scroll through the thumbnails to see how the overall layout of your eBook appears to a Kindle 

customer.  
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• In the Preview Options section, use the Page Size slider to increase or decrease the size of the 

thumbnails.  

• To get a full view of the thumbnails, set the Page Size slider in a position comfortable for you 

and close the Previewer pane (see Figure 7).  

• To bring back the Previewer pane, click a thumbnail. 

 

Figure 7: Full view of thumbnails 

Note: If you see a tablet device window and no thumbnails, it might be because your eBook is fixed-

layout or does not support Enhanced Typesetting (see section 2.1 for details). 

1.8.3 Previewer Pane  

The Previewer pane emulates the appearance of your eBook on a selection of device types such as 

tablet, phone, and Kindle E-reader.  

• By clicking the top menu, you can access options to open and close eBooks, change settings, 

navigate through your eBook, and view online help options. 

• Use the Preview and Navigation Options pane to navigate through your eBook, turn on 
Auto-Advance View, and select Auto Advance speed.  

• Use the View All list or the Navigation menu to navigate across aspects of your eBook, such 
as the Table of Contents, sections, images, lists, drop caps, and links.  

o The View All list is only available if your eBook supports Enhanced Typesetting as 
described in section 2.1. 

• In the Preview and Navigation Options pane, use Location to go to a specific location. 
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• Use the Search box to find text in reflowable eBooks (see Figure 8). Select the Match Case 
option, if applicable. Clicking a thumbnail in the search results takes you to that page in the 
Previewer pane and highlights the corresponding text. From here, you can also use Auto-
Advance View to automatically navigate through the search results.  

 

Figure 8: Search box 

• When previewing a table in the Previewer pane, you can click the Expand icon to open Table 
Viewer (see Figure 9) and preview the entire table, just as customers will be able to do while 
reading your book on Kindle reading devices and applications. 

  

Figure 9: Table Viewer 

1.9 Changing Default Device Settings 

To change your default device, orientation, and/or aspect ratio 

1.  Select View > Preferences. The Preferences dialog box is displayed (see Figure 10). 
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Figure 10: Preferences dialog box 

2. Click the Default device, Aspect ratio, and/or Default orientation options to change your 

settings. 

• When the Default device is Tablet, the Aspect ratio list is displayed as shown in Figure 

10. If the Default device is Phone or Kindle E-Reader, the Aspect ratio option is not 

displayed because Kindle Previewer uses a single device ratio for each of those device 

options. 

3. Click Save to save your changes. 

1.10 Keyboard Shortcuts 

You can use the following keyboard shortcuts in Kindle Previewer. 

Action Windows Shortcut Mac Shortcut 

Display Keyboard Shortcuts CTRL + K CMD + K 

Open Book CTRL + O CMD + O 

Close Book CTRL + W CMD + W 

Export CTRL + X CMD + X 

Conversion Log CTRL + G CMD + G 

Book Information CTRL + I CMD + I 

Preferences CTRL + , CMD + , 

Auto Navigate Space Space 

Go to Next Page Right Arrow Right Arrow 

Go to Previous Page Left Arrow Left Arrow 

Go to Next Section CTRL + Right Arrow CMD + Right Arrow 
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Action Windows Shortcut Mac Shortcut 

Go to Previous Section CTRL + Left Arrow CMD + Left Arrow 

Go Back CTRL + B CMD + B 

Go to Cover CTRL + R CMD + R 

Go to Beginning CTRL + S CMD + S 

Go to End CTRL + E CMD + E 

Go to First Page CTRL + SHIFT + F CMD + SHIFT + F 

Go to Location CTRL + L CMD + L 

Table of Contents CTRL + T CMD + T 

Rotate Screen CTRL + SHIFT + R CMD + SHIFT + R 

Copy User Location CTRL + U CMD + U 

Copy File Position CTRL + P CMD + P 

Previous Image F3 Fn +F3 

Next Image F4  Fn + F4  

Pan Up W  W  

Pan Down S  S  

Pan Left A  A  

Pan Right D  D  

Zoom In CTRL + = CMD + = 

Zoom Out CTRL + - CMD + - 

Set Font CTRL + Up Arrow/Down Arrow CMD + Up Arrow/Down Arrow 

Next Color Mode SHIFT + C SHIFT + C 

Next Device SHIFT + D SHIFT + D 

Next Font SHIFT + F SHIFT + F 

1.11 Automatic Updates 

When Amazon releases a new version of Kindle Previewer, the application automatically downloads it 

for you. When Kindle Previewer prompts you to install an update, we recommend that you install the 

newest version to get all of the latest features. On Mac OS X, once the new version is downloaded, 

Kindle Previewer will be automatically updated when you close the application. You can also run 

“kindlepreviewer –update” from a command-line interface to download and install the latest update. 
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1.12 Format books with Kindle Create 

You can format, style and preview your books using Kindle Create, a free tool that helps you 

automatically transform your completed manuscript into a beautifully formatted Kindle eBook. It comes 

with a built-in previewer that will help you preview your book, similar to Kindle Previewer. Kindle Create 

is available on Mac OS X and Windows PC, and supports English and other Latin languages.” 

1.13 Kindle Publishing Guidelines 

The Amazon Kindle Publishing Guidelines provide guidance on how to format and test eBooks, and 

suggest best practices for Kindle publishing. See a PDF of the guidelines. 

1.14 Send Feedback 

We would love to know what you think about Kindle Previewer. Tell us what you like about it and what 

we can improve.  

If you are willing to be contacted about your feedback, you can sign in using the Amazon credentials you 

use to publish on Kindle by selecting Sign In. Although Amazon does not contact all users who provide 

feedback, signing in allows us to contact you if we need additional information to address your 

feedback.  

To send us your feedback, click the menu and select Help > Send Feedback. You can rate your overall 

experience with Kindle Previewer and give us any other feedback that you may have.  

1.15 Frequently Asked Questions 

For the most current FAQ and troubleshooting tips, please visit our Kindle Previewer page. 

https://www.amazon.com/Kindle-Create/b?ie=UTF8&node=18292298011
http://kindlegen.s3.amazonaws.com/AmazonKindlePublishingGuidelines.pdf
https://www.amazon.com/gp/feature.html?docId=1000765261


      

 

Amazon.com page 18 

2 Previewing Your eBook 

To preview your eBook: 

1. Drag and drop the file into the Previewer pane or select File > Open Book and then select the 
file. Your eBook is imported and displayed in Kindle Previewer (see Figure 11).  

 

Figure 11: Imported eBook 

2. Page through your eBook in multiple device modes to test how it appears in Kindle devices 
and applications. Amazon suggests: 

• Use the options in the Navigation section of the Preview and Navigation Options pane 
to navigate through your eBook. You can also turn on Auto-Advance View and/or adjust 
Auto Advance speed. 

• Use the Preview Options section of the Preview and Navigation Options pane to change 
the device, orientation, font, and/or font size.  

• If your eBook can utilize Enhanced Typesetting, use the Page Size slider to adjust the 
zoom in the Thumbnail pane.  

• Use the Table of Contents section to view and explore your eBook’s navigation file.  

• Use the View All list or the Navigation menu to navigate across aspects of your eBook, 
such as the Table of Contents, sections, images, lists, drop caps, and links.  

o The View All list is only available if your eBook supports Enhanced Typesetting as 
described in section 2.1. 

• While previewing a tablet or phone, change the background color by selecting View > 
Color Mode and then choosing White, Black, Sepia, or Green to confirm your eBook's 
readability on different background colors. (Note: Green is not available on iOS. 
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Background colors cannot be changed on e-Ink devices.) 

3. When you have finished previewing your eBook, click the Close button at the top of Kindle 
Previewer.  

2.1 Enhanced Typesetting 

Kindle Previewer allows you to determine if your eBook is able to utilize Enhanced Typesetting. 

Enhanced Typesetting is a series of typographical and layout features that improve readability and 

enforce more consistent display behavior across Kindle reading platforms, including phones, tablets, and 

Kindle E-readers. Some Enhanced Typesetting features include: 

• Drop caps that dynamically adjust with font size 

• Hyphenation and smoother word spacing* 

• Kerning and ligature improvements* 

• Enhanced image and table formatting 

• Page Flip 

*Note: These features might not apply to Japanese and Chinese content. 

To determine if your eBook is able to utilize Enhanced Typesetting, first import your eBook into Kindle 

Previewer. If your eBook supports Enhanced Typesetting, the Enhanced Typesetting label is displayed in 

the Preview and Navigation Options pane as shown in Figure 12 and the Thumbnail pane is displayed as 

shown in Figure 13. If Enhanced Typesetting is not enabled, the Enhanced Typesetting label and the 

Thumbnail pane are not displayed. 

 

Figure 12: Preview and Navigation Options pane—Enhanced Typesetting enabled 
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Figure 13: Workspace with Enhanced Typesetting enabled 

2.2 Viewing the eBook Metadata 

You can view the eBook metadata for any eBook imported into Kindle Previewer (see Figure 14). To view 

the metadata, click the menu and select View > Book Information. 

 

Figure 14: Book Information 
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3 Using Kindle Previewer from a command-line interface 

To validate multiple books, you can run Kindle Previewer from a command-line interface. 

Usage instructions: kindlepreviewer <input> <-command(s)> [-option(s)] 

• Input: Specify the input file name here when processing a single file, or the input folder when 

processing multiple files. 

• Command(s): Include at least one of the commands specified in this table: 

Commands 

-convert Create a KPF file in the specified output path or a Mobi file if the book doesn’t 

support Enhanced Typesetting. Use the Enhanced Typesetting-compatible KPF 

file to open the book in Kindle Previewer's graphical user interface. 

-showpreview Open the converted book in Kindle Previewer's graphical user interface. This will 

first convert the book, and then open it for preview.  

-log Use this option to generate only the log files for validation without generating a 

KPF or a Mobi file. 

 

• Option(s): Choose any of options specified in this table (optional): 

Options 

-output <output 

path> 

Path to the output folder. Use this option to specify a preferred path to store 

output file(s) instead of the default path (input folder). 

-locale <locale-

option> 

Specify your preferred locale. Use this option to set the language for conversion 

log messages and the Kindle Previewer user interface. Supported locales: 

• en (English) 

• de (German) 

• fr (French) 

• it (Italian) 

• es (Spanish) 

• zh (Chinese) 

• ja (Japanese) 

• pt (Portuguese) 

• nl (Dutch) 

 

Usage examples: 
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Validate multiple files: You can validate multiple files by providing a folder containing the files 

as the input. To check the status of all the files, you can use the summary log file in the 

“output/”folder. To review errors or warnings, use the individual log file inside the “output/log/” 

folder. Example: “kindlepreviewer inputfolder/  -convert -output outputfolder” 

 

• Validate files individually: You can use Kindle Previewer to process files individually and 

generate a KPF file, which is compatible with Enhanced Typesetting. There are three options: 

• Use the “-showpreview” command to automatically open the book on the Kindle 

Previewer graphical user interface without reconverting it. 

• Use the KPF file to manually open the book without reconverting it. 

• Use the individual log file inside the “output/log/” folder to review any errors or 

warnings. 

 

Example: “kindlepreviewer inputfile.epub –convert” or “kindlepreviewer inputfile.epub –

showpreview” 

 

• Generate log files only: You can use the “–log” command to validate books and generate just 

the log files (summary log file, and the individual log files), without generating any output file. 

Example: “kindlepreviewer inputfolder/ -log” 
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